Cómo las actualizaciones de PHP de su proveedor de alojamiento web afectan sus sitios de WordPress

Uno de nuestros usuarios se puso en contacto con nosotros recientemente acerca de un aviso de su proveedor de alojamiento sobre la actualización a una nueva versión de PHP.

WordPress está escrito en el lenguaje de programación PHP. Es un lenguaje del lado del servidor, lo que significa que se ejecuta en su servidor de alojamiento web para generar páginas de WordPress de forma dinámica.

En este artículo, explicaremos cómo las actualizaciones de PHP de su proveedor de alojamiento web afectan sus sitios de WordPress. También discutiremos las cosas que puede hacer para evitar conflictos o tiempo de inactividad en su sitio web.

Una actualización de PHP desde su proveedor de alojamiento web debería realizarse sin problemas, pero también puede salir muy mal. Todo depende de su proveedor de alojamiento web y de cómo configuran sus servidores.

Es por eso que recomendamos a nuestros usuarios que elijan el mejor alojamiento de WordPress, para que sepan que hay ingenieros de primer nivel que se encargan de esos servidores.

La elección de un servidor web no confiable para su sitio de WordPress puede causar un tiempo de inactividad inesperado durante o después de la actualización, y no hay prácticamente nada que pueda hacer al respecto más que cambiar a un mejor host.

Actualizaciones de WordPress y PHP

WordPress se desarrolla utilizando el lenguaje de programación de código abierto PHP. En el momento de escribir este artículo, WordPress requiere al menos la versión 5.6.20 o posterior de PHP. La versión estable actual disponible para PHP es 7.3.8.

La mayoría de los proveedores de alojamiento compartido ofrecen actualmente la versión 7.0 de PHP. + Instalado en sus propios servidores.

Algunos servidores web pueden incluso permitirle cambiar su versión de PHP desde su panel de control. Hay varias razones para que los servidores web no utilicen las últimas versiones de PHP estables y de última generación, pero la razón más común es que las últimas versiones a veces pueden romper algunas aplicaciones de PHP.

Sin embargo, tampoco quieren quedarse atrás. Actualmente PHP 5.6. + Es la versión mínima requerida y generalmente se recomienda php 7.0+.

Cosas que debe hacer cuando su host actualiza PHP

Su proveedor de alojamiento web probablemente ya alberga miles de sitios de WordPress. Tomarán todas las precauciones posibles para asegurarse de que todo salga bien y de que los clientes no experimenten ningún problema en el servicio.

El aviso que recibió le permite estar informado sobre la actualización y vigilarla para ver si algo sale mal. Si bien es poco probable que esta actualización rompa las cosas, siempre es bueno tener un plan de respaldo.

En primer lugar, siempre recomendamos a nuestros usuarios que realicen copias de seguridad de sus sitios de WordPress con regularidad. Si no tiene una solución de copia de seguridad automática como BackupBuddy, VaultPress o BackWPup, es hora de instalar una o al menos crear una copia de seguridad manual de su sitio web.

Después de las copias de seguridad, lo siguiente que debe hacer es asegurarse de estar ejecutando la última versión de WordPress. También asegúrese de que todos sus plugins y temas estén actualizados.

Vaya a la pantalla Actualizaciones e instale las actualizaciones disponibles.

El propio WordPress y los plugins de WordPress más populares no se verán afectados por la actualización de PHP. Sin embargo, algunos plugins pueden dejar de funcionar.

Si un plugin en su sitio dejó de funcionar debido a una actualización de PHP, debe comunicarse con el autor del plugin para obtener ayuda o encontrar una alternativa.

¿Qué hacer si una actualización de PHP daña su sitio de WordPress?

Hay muy pocas posibilidades de que una actualización de PHP rompa su sitio de WordPress. Sin embargo, con la abundancia de plugins gratuitos y de pago, una sola línea de código de mala calidad puede generar un error.

Lo primero que debe hacer es asegurarse de que no sea un plugin o tema el que esté causando este error. Para hacer esto, desactive todos sus plugins de WordPress y cambie a un tema predeterminado de WordPress.

Si esto no resuelve su problema, comuníquese con el equipo de soporte de su proveedor de alojamiento web. Existe una buena posibilidad de que el problema al que se enfrenta ya se les haya comunicado y puedan ayudarlo.

Si su proveedor de alojamiento web no puede ayudarlo, intente instalar una copia nueva de WordPress y luego restaure su sitio de WordPress desde la copia de seguridad.

Si nada de esto ayuda, tal vez sea hora de cambiar su alojamiento de WordPress.

Esperamos que esta guía le haya ayudado a comprender cómo las actualizaciones de PHP de su proveedor de alojamiento web afectan su sitio de WordPress. Para comentarios y preguntas, deje un comentario a continuación.

¿Te ha resultado útil??

0 / 0

Deja una respuesta 0

Tu dirección de correo electrónico no será publicado. Required fields are marked *